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COPYRIGHT STATEMENT  

The content (content being images, text, programs and scripts) of this English 

manual is copyright © FriendlyARM Co., Ltd. All rights expressly reserved. 

Any content of the manual printed or downloaded may not be sold, licensed, 

transferred, copied or reproduced in whole or in part in any manner or in or on any 

media to any person without the prior written consent of FriendlyARM Co., Ltd 

including but not limited to: 

 transmission by any method  

 storage in any medium, system or program  

 display in any form  

 performance  

 hire, lease, rental or loan  

 Requests for permission to reproduce material from this manual should be addressed 

to FriendlyARM Co., Ltd. 
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Before step into this guide we recommend users to read our dummy book to 

obtain some handson experiences about the Mini6410 system. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 6 / 137 

 

1 Get Started with WinCE 6 

The image file for WindowsCE6 is under “\images\WindowsCE6”.Please follow the steps 

described in our previous chapters to burn a WinCE 6 image into the board (we used 

NK_T43-i.bin which is for 4.3”LCD and supports 1-wire precise touching). After your 

burning is done please toggle the S2 switch to the Nand Flash and reboot the system. 
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1.1 Calibrate Touch Screen 

The default WinCE system’s touch screen parameters are for NEC 4.3”LCD. Other LCD 
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systems may require different settings therefore users need to re-calibrate the screen. Below 

are the steps: 

Step 1: connect a USB mouse to your board, go to “Start -> Settings -> Control Panel”, 

locate the “Stylus” icon, double click to open its property window and click on “Calibrate -> 

ReCalibrate”  

 

Follow the system’s prompt to start calibration. After you are done you will see the 

following screen. Click on any position you will return to the property window. Please click 

on “OK” to save and exit. 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 9 / 137 

 

 

If you want to save the setting, you can go to “Start -> Suspend” and reboot. 
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1.2 Verify Touch Pen 

Click on the “painter” icon on the desktop. You can randomly touch the screen to test the 

touch screen’s response  

1.3 Check System Info 

Go to “start -> Settings -> Control Panel -> System” and you can check your system info. 

Or you can right clickon “My Device -> Property”. 
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1.4 Set Time Zone and Date 

Click on the time area on the bottom right corner, the time setting interface will pop up. 

You can just follow its prompts to set time and date. Click on “OK” to save and return and 

your settings will be saved 
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1.5 Nand Flash Memory 

Open “My Device”, you will see a “NandFlash” icon. Users can save data in it and will not 

lose it even after the system is powered off. 
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1.6 Use Flash Drive/SD Card 

In WinCE we can use use flash drives. After WinCE is booted insert a USB flash drive 

into the host socket, seconds later the drive will be automatically mounted. Double click on 

“My Device” and you will see it. Then you can enter it and operate your files.  

You can do it the same way for SD cards. Insert an SD card into the SD card socket and 

you will see it listed as “Storage Card”. Enter it and you will be able to operate your files. 
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1.7 Play MP3 

Users can use WinCE’s MediaPlayer to play mp3 
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1.8 Test LED 

Go to “FriendlyARM”, click on “LED-Test” you will see the following dialog and you can 

manipulate LEDs by clicking on the buttons on it 

 

 

 

1.9 Test User Button 

Go to “FriendlyARM”, click on “Buttons” you will see the following dialog. Clicking on 

the buttons you will observe their color changes 
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1.10 Test PWM Buzzer 

Go to “FriendlyARM”, click on “PWM-Buzzer” you will see the following dialog. Click 

on “Start” you can test its beeping. Click on “Stop” you can stop it. 

 

 

 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 17 / 137 

 

1.11 Audio Recording 

Go to “FriendlyARM”, click on “Recorder”. 

 

 

 

Click on “Record” to begin recording. Now if you speak to the microphone on the board 
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your voice will be recorded. Click on “Stop” to stop redording 

 

Click on “Play” it will loop the audio you just recorded.  

Note: this utility doesn’t save the recorded audio file. 

 

1.12 Serial Port Assistant 

Note: the Mini6410 BSP includes drivers for three standard serial ports: COM1, 2, 3 and 4. 

To test these three ports you need our extension board. Please hook up your extension board 

as follows: 
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Go to “FriendlyARM” and click on “SerialPort”, you will see the following dialog 
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Click on “Settings”, select COM2, set its bit rate to 115200, click on “OK” to save it. 

Meanwhile connect your extension board(COM2) to PC, set up your PC’s corresponding 

COM.  

In the main window, click on the “Open” button, (the button’s title will change to “Close”), 
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type some characters in the edit area and click on the “Send” button. You will see the 

characters you typed received in your PC. 

 

 

In the Serial Port Assistant’s main window, click on the “Receive” button (its title will 

change to “Not Receive”), type some characters in the edit area of your PC’s serial port 

window, you will see the characters you typed received in the Assistant’s main window 
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We can follow this procedure to test COM3 and COM4 too 

 

1.13 Preview with CMOS Camera 

The Mini6410 supports all CMOS cameras that are supported in the Mini2440 system 

because they use the same interface. Before power on your system please connect your 

CAM130 to the CMOS camera interface on your board (Mini6410’s CON10) 

 

 

Click on the “Camera” icon 
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The following dialog will pop up after the utility is launched 

 

 

1) Taking Pictures  

  To take a picture you can click on “Snap” and your picture will be saved in 

\NandFlash\Camera\.To browse your pictures, you can click on “Brower” to select files from 

\NandFlash\Camera\. 
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Double click on your selected picture, it will be opened in your IE as follows 

 

 

Click on “X” on the upper right of the screen you can close it and return to the main menu 

 

2) Video Clip  
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In the main menu, click on “Record” you will begin to take video clips. During the 

process the status bar will show “Recording”. Our Demo program lasts 5 seconds and the 

clip will be saved in \NandFlash\Camera\. The saving process takes about 50 seconds 

 

  If “Saving video file, pls wait…” disappears it indicates the clip has been saved. Click on 

“Brower” you can  

play it. 
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Double click on you selected video to play it 

 

Click on “Exit” you will exit the program and see the following dialog asking if you want 

to delete the picture you just saved in \NandFlash\Camera\. If you don’t need it just go by 

“Yes”. 
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1.14 “Hard Decoding” Player 

  We developed a “hard decoding” player in our Mini6410 system that is able to play 

720x480 30fps or 720x576 25fps Mpeg4, H264, H263 videos. (We are the first one to 

implement this feature in Linux). This player has the following excellent features: 

- it can automatically recognize Mpeg4, H264 and H263 files and switch to hard decoding  

play. That is to say if your Mini6410 platform doesn’t support hard decoding it can play  

these files too although it may not play that smoothly  

- elegant playing 

- utilizes the DirectDraw technology 

This player is integrated in WinCE (its icon is on the desktop). We provided with two test 

videos which are under “\test videos”. You can copy them (one is a H.264 file and the other 

is a MPEG4 file) to your SD card. Click on the “player” icon on WinCE’s desktop.  

Note: when you launch this utility in a newly installed WinCE it maynot run that fast. 
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Go to “File -> Open File” to select your video file 
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Double click on your file and it will be played 

 

Note: the maximum hard decoding resolution the Mini6410 system can support is 720x480 

therefore when you play a video in a 7” LCD in full screen it may not go very smoothly. You 

can go to “Options->View->Zoom->100%” and “Options->View->Pixel Aspect Ratio” and 

click on full screen to fix this issue. For other LCDs you can make adjustments accordingly. 

 

1.15 Test TV-OUT 

Go to “FriendlyARM” and click on “TV” 
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Set your TV’s input to CVBS and connect it to your board with our shipped yellow calbe. 

Click on “LCD + TV”, the output will be directed to your TV simultaneously 

 

Click on “LCD”, the output will be directed to your LCD 
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1.16 Configure MAC Address 

The integrated DM9000 network card doesn’t come with a MAC address therefore we  

strongly recommend our users to set it prior to connecting to the internet after burning an 

image into the board. 

After you set up your MAC address it will be written into the registry and will be there 

forever unlessyoureinstall you system or update it.Click on the “iMAC” icon to start the 

utility.  

 

 

 

On the MAC Address setting dialog, “Old” shows the current MAC. You can type your 

new in “New” or click on the “Gen”button to generate a ramdom MAC which in general 

achieves better results: 
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The following screens shows a MAC generated by “Gen” 

 
 

Click on “Update MAC” to save your MAC into the registry and reboot your system 
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After system is rebooted you MAC will take into effect 

 

1.17 Configure Ethernet 

Before you can browse the internet you need to set up your IP, gateway and DNS 

properly.Please go to “Start -> Settings->Control Panel”, launch the network setting utility 

and locate your DM9CE1. 

 

 

Double click on the DM9CE1 icon, you will see the following dialog in which you can 
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make your network configurations. 

 

 

After setting up your network properly you can try it now 
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1.18 Use SD Wifi Card 

Before boot your system, please connect an SD-WiFi to your board’s SDIO (CON9). 

 

Boot the system and you will see the SD WiFi’s green led is flashing and it is searching 

for a nearby network. The following dialog will pop up if it does find one 

 

Select a network, click on “Connect” and type the required information to connect 
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Click on “OK” on the upper right of the dialog you will see the following dialog if your 

connection is successful. 

 

 

1.19 Use USB Wifi Card 

The Mini6410 system(WinCE) by default integrates the driver for Ralink RT2070/RT3070 

USB WiFi networkcard. This card is plug and play. Its configuration GUI is the same as the 

SD WiFi GUI. The following screenshot is the GUI 
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The other configurations are the same as the SD WiFi configurations 

 

1.20 Use USB Bluetooth 

The Mini6410 system(WinCE) by default integrates the USB bluetooth driver. This driver  

is not from the third party but comes with WinCE. You only need to configure it. In our 

example project we have configured this option therefore you can plug and play your USB 

Bluetooth. One thing to remind users is that it doesn’t guarantee to support all USB 

Bluetooth modules  

Below are the steps to follow:  

Hook up your bluetooth module to your board and go to “Control Panel->Bluetooth 

Devices”  
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Click on “Scan Device” to search for neaby Bluetooth devices. In our example it found a 

cell phone 

 

Click on “” to add your device to “Trusted” and you will see the following dialog 

 

Click on “Yes” a verification dialog will pop up, you can type several digits randomly 

such as “111” and you will have a dialog on your phone, type the same digits you did and 
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your device will be added to “Trusted” 

 

This way a trusted channel between your board and your cell phone will be established. 

After you send a file form your cell phone you will see a dialog on your board 

 

Click on “Yes” to accept it and the file will be saved under “Documents\DefaultInbox” 

 

 

1.21 Backlight Control 

If your system is preinstalled with WindowsCE6, you may notice that your LCD backlight  

will turn off if it doesn’t accept any touch within 30 seconds. This is manipulated by the 

backlight control function. 4.3” and 7” LCDs that have the 1-wire precise touch function 
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have the backlight control function.In WinCE the backlight control driver utilizes standard 

system interfaces and you can easily manipulate it via software. 

Please go to “Control Panel -> Display”  

 

Click on the “backlight” tab you will be able the set its turn-off time. By default it is 30 

seconds 
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Click on “Advanced” 
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The backlight control window will pop up 
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You can slide the slider to adjust the backlight. Click on “close” to return to your previous 

interface 

 

1.22 Synchronize with PC (for Windows7) 

Note: in Windows 7, you don’t need ActiveSync! Please make sure your PC can connect to 

the internet. 

In Windows 7 the synchronization is implemented via “Windows Mobile Device” 

(Synchronization Center) which is similar to ActiveSync. Below is its interface 
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The “Synchronization Center” doesn’t come with Windows 7 and needs to be installed. 

Below are the steps to follow for Windows 7: (Note: if your board runs WinCE6 you still can 

connect your board to your PC via ActiveSync.)  

Install Windows Mobile Device Center 

Power on your board that runs WinCE6, connect it to a PC that runs Windows 7 via USB 

you will see the following window 
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Soon you will see the following window 

 

If your system is connected to the internet it will automatically download and install 

related software 

 

After installation is done, you will see the following configuration dialog click on “Accept” 

on the license window 
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You board is now connected to your PC 
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Click on “Connect” 
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Click on “File Management -> Browse” you will enter the board’s root directory. If your 

board has a SD card or USB drive connected it will be listed here too 
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Now you can manipulate your files between your PC and board 
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2 Set up WinCE 6 Development Environment 

Note: the following softare and installation steps are based on Windows 7 (flagship version). 

We recommend users to copy the installation software to your hard disk to install 

 

 

Installation of Windows CE 6.0 is complicated and has lots of requirements for hardware 

therefore we strongly suggest users exactly follow our installation steps:  

Below are the basic system requirements 

CPU: Intel Core Duo E8400  

RAM: DDR2 4GB  

Hard Disk: 500GB 

Software List (We don’t offer Windows Embedded 6.0 CE 6 installation files and users 

may need to download its trial version from Microsoft’s website):  
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Visual Studio 2005  

(trial version download website:  

http://download.microsoft.com/download/e/1/4/e1405d9e-47e3-404c-8b09-489437b27fb0/E

n_vs_2005_Pro_90_Trial.img )  

Visual Studio 2005 Service Pack 1(file name: VS80sp1-KB926601-X86-ENU.exe)  

Download website: 

http://www.microsoft.com/downloads/details.aspx?familyid=bb4a75ab-e2d4-4c96-b39d-37b

af6b5b1dc&displaylang=en  

Visual Studio 2005 Service Pack 1 Update for Windows Vista (文件名：

VS80sp1-KB932232-X86-ENU.exe)  

Download website:  

http://www.microsoft.com/downloads/details.aspx?FamilyID=90E2942D-3AD1-4873-A2EE

-4ACC0AACE5B6&displaylang=en)  

Visual Studio 2005 Service Pack 1 ATL Security Update 

(VS80sp1-KB971090-X86-INTL.exe)  

Download website:  

http://www.microsoft.com/downloads/details.aspx?familyid=7C8729DC-06A2-4538-A90D-

FF9464DC0197&displaylang=en  

Windows Embedded CE 6.0  

Trial version download website:  

http://download.microsoft.com/download/e/1/4/e1405d9e-47e3-404c-8b09-489437b27fb0/En_vs_2005_Pro_90_Trial.img
http://download.microsoft.com/download/e/1/4/e1405d9e-47e3-404c-8b09-489437b27fb0/En_vs_2005_Pro_90_Trial.img
http://www.microsoft.com/downloads/details.aspx?familyid=bb4a75ab-e2d4-4c96-b39d-37baf6b5b1dc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=bb4a75ab-e2d4-4c96-b39d-37baf6b5b1dc&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=90E2942D-3AD1-4873-A2EE-4ACC0AACE5B6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=90E2942D-3AD1-4873-A2EE-4ACC0AACE5B6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=7C8729DC-06A2-4538-A90D-FF9464DC0197&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=7C8729DC-06A2-4538-A90D-FF9464DC0197&displaylang=en
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http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7e286847-6e

06-4a0c-8cac-ca7d4c09cb56 



Windows Embedded CE 6.0 Platform Builder Service Pack 1  

Download website: 

http://www.microsoft.com/downloads/details.aspx?FamilyId=BF0DC0E3-8575-4860-A8E3-

290ADF242678&displaylang=en  

Windows Embedded CE 6.0 R2  

Download website: 

http://www.microsoft.com/downloads/details.aspx?FamilyId=F41FC7C1-F0F4-4FD6-9366-

B61E0AB59565&displaylang=en  

Windows Embedded CE 6.0 R3  

Download website: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=BC247D88-DDB6-4D4A-A5

95-8EEE3556FE46&amp;displaylang=ja&displaylang=en  

Tencent QQ (third part software)  

Download website: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=527042f7-bb5b-4831-a6ad-50

81808824ec&displaylang=en  

WesttekFileViewers6.exe(office file manager, third part software)  

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7e286847-6e06-4a0c-8cac-ca7d4c09cb56
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7e286847-6e06-4a0c-8cac-ca7d4c09cb56
http://www.microsoft.com/downloads/details.aspx?FamilyId=BF0DC0E3-8575-4860-A8E3-290ADF242678&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=BF0DC0E3-8575-4860-A8E3-290ADF242678&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=F41FC7C1-F0F4-4FD6-9366-B61E0AB59565&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=F41FC7C1-F0F4-4FD6-9366-B61E0AB59565&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=BC247D88-DDB6-4D4A-A595-8EEE3556FE46&amp;displaylang=ja&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=BC247D88-DDB6-4D4A-A595-8EEE3556FE46&amp;displaylang=ja&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=527042f7-bb5b-4831-a6ad-5081808824ec&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=527042f7-bb5b-4831-a6ad-5081808824ec&displaylang=en
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Download website:  

http://www.microsoft.com/downloads/details.aspx?FamilyID=d2fd14eb-7d5c-428b-951c-34

3f910047c1&displaylang=en  

The above list also indicates the order of installing these software components:Visual 

Studio 2005and its patches first, then Windows CE 6.0 and its patches and finally the third 

party software  

Note: the Platform Builder for Windows CE 6.0 is different from its previous versions such 

as Windows CE 5.0/4.2. It is not a standalone software application but a plugin of VS2005 

and therefore depends on VS2005. You need to install VS2005 first. All the configurations 

and compilation described below are with VS2005. 

Here are the steps: 

 

2.1 Install Visual Studio 2005 and Patches 

Step1：enter the Visual Studio 2005 directory and double click on “setup.exe” 

http://www.microsoft.com/downloads/details.aspx?FamilyID=d2fd14eb-7d5c-428b-951c-343f910047c1&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=d2fd14eb-7d5c-428b-951c-343f910047c1&displaylang=en
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Step2：click on “Install Visual Studio 2005” to continue 
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Step3：click on “Next” to continue 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 56 / 137 

 

 

 

Step4: check the redly marked box and enter your serial number, click on “Next” to continue 
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Step5: select your installation features, please check “Full” and click on “Next” to continue 
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Step6: the following screen kicks off the installation of Visual Studio 2005 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 59 / 137 

 

 

 

Step7: after Visual Studio 2005 installation is done please click on “Finish” on the dialog 

shown below 
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Click on “Exit” on the dialog shown below 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 62 / 137 

 

 

Step8: now we will begin to install “Visual Studio 2005 Service Pack 1”. Double click on 

“VS80sp1-KB926601-X86-ENU.exe” to begin installation 
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Step9: click on “OK” on the following dialog 

 

Step10: click on “I accept” on the license dialog 

 

Step11: the following dialog kicks off the installation. The whole process may take a while. 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 64 / 137 

 

 

Step12: after installation is done click on “OK” on the following dialog 

 

Step13: now we will begin to install the second patch “Visual Studio 2005 Service Pack 1 

Update for Windows Vista”. Double click on “VS80sp1-KB932232-X86-ENU.exe” 

 

 

Step14: click on “OK” to continue 
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Step15: on the following license dialog click on “I accept” 

 

Step16: the following screen kicks off the installation. This may take a while 

 

Step17: after the installation is done click on “OK” to finish 
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Step18: now we will begin to install the third patch “Visual Studio 2005 Service Pack 1 ATL 

Security Update”. Double click on “VS80sp1-KB971090-X86-INTL.exe” 

 

 

 

Step19: click on “OK” to continue 
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Step20: on the license dialog click on “I accept” 

 

Step21: the following screen kicks off the installation. This may take a while 

 

Step22: after the installation is done click on “OK” to finish 
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We have completed our installation of Visual Studio 2005 and its patches on Windows7 

 

2.2 Install Windows CE 6.0 and Patches 

This section will guide you through the steps on how to install Windows CE 6.0 Platform 

Builder. 

Note: to install Windows CE 6.0 and its patches on Windows 7 you need to do it as 

administrator. You cannot just double click on the setup.exe to install. Please strictly follow 

the steps below  

Step1: go to “Start”->“Programs”->“Accessories”, locate the command line utility, right 

click on it and select “run as administrator”  
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Step2: enter the installation directory, type “Windows Embedded CE 6.0.msi” and press 

“return” 
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Step3: click on “Next” to continue 
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Step4: type the product key and click on “Next” 
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Step5: check “I accept” on the license dialog and click on “Next” to continue 
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Step6: follow the options marked redly as below and click on “Next” to continue 
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Step7: follow the options mared redly as below and click on “Next” to continue 
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Step8：click on “Install” to continue 
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Step9: the installation is kicked off and it may take a while 
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Step10: after the installation is done click on “Finish” to complete 
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Step11: now we will begin to install a patch “Windows Embedded CE 6.0 Platform Builder  

Service Pack 1.msi”.Open the command line utility as administrator, enter the directory, type  

“Windows Embedded CE 6.0 Platform Builder Service Pack 1.msi” and press “return” 
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Step12: click on “Next” to continue 
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Step13: check “I accept” and click on “Next” to continue 
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Step14: click on “Next” to continue 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 82 / 137 

 

 

 

Step15: the installation is kicked off and it may take a while 
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Step16: after the installation is done, click on “Finish” to complete 
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Step17: now we will begin to install the second patch “Windows Embedded CE 6.0 R2.msi”. 

Please follow the previous steps to launch the command line utility, type “Windows 

Embedded CE 6.0 R2.msi” and press “return”  

Note: some users may download a “Windows Embedded CE 6.0 R2.msi” which is about 

50MB. But this is not a complete installation file. We suggest our users use our R2 patch 

which is about 1.01GB 
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Step18: click on “Next” to continue 
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Step19: check “I accept” and click on “Next” to continue 
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Step20: click on “Next” to continue 
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Step21: click on “Next” to continue 
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Step22: the installation process is kicked off and this may take a while 
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Step23: after the installation is done, click on “Finish” to complete 
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Step24: now we will begin to install R3. Please follow the previous steps to launch the 

command line utility, type “Windows Embedded CE 6.0 R2.msi” and press “enter”  

Note: some users may download a “Windows Embedded CE 6.0 R3” which is an image file. 

In order for users to use it more conveniently we make it a directory which contains 166 files 

that are about 1.14GB 
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Step25: click on “Next” to continue 
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Step26: check “I accept” and click on “Next” to continue 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 94 / 137 

 

 

 

Step27: click on “Next” to continue 
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Step28: the installation is kicked off and it may take a while 
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Step29: after the installation is done, click on “Finish” to complete 
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2.3 Install Tencent QQ (a Third Party Messenger) 

Windows CE 6.0 R3 includes some third party software such as Tencent QQ and File 

Viewers. We have burned it into our shipped CD and you can also download it from the 

following website: 

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=bc247d88-dd

b6-4d4a-a595-8eee3556fe46#filelist .  

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=bc247d88-ddb6-4d4a-a595-8eee3556fe46#filelist
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=bc247d88-ddb6-4d4a-a595-8eee3556fe46#filelist
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We will intall QQ as an example for you. 

Step1: enter the QQ directory, double click on the “setup.exe” executable. 

 

 

Step2: click on “Next” to continue 
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Step3: follow the default options and click on “Next” to continue 
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Step4: check “I agree” on the license dialog and click on “Next” to continue 

 

Step5: click on “Next” to continue 
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Step6: the installation is kicked off. 
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Step7: click on “Close” to complete 
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2.4 Install BSP and Sample Programs 

The Mini6410 BSP and it project file can be installed by running 

“Mini6410-WinCE6-Suite-1030” (1030 is the date when we released it. Our latest file one 

may have a different date, please refer to our CD). Users can download this file from 

http://www.arm9.net . Below are the steps to follow  

Step1: locate the “Mini6410-WinCE6-Suite-1030” executable and double click on it 

http://www.arm9.net/
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Step2: follow the default options and click on “Install” to continue 
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Step3: the installation is kicked off and very short since the file is very small 
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Step4: after the installation is done, click on “Close” to complete 
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A SMDK6410 BSP directory will be created under “WinCE600\PLATFORM” 
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Three directories for three languages will be created under “WinCE600\OSDesigns”: 

Mini6410 - Simplified Chinese  

Mini6410-en - English 

Mini6410-tw – Tranditional Chinese  

 

 

 

 

Now you have successfully set up your Windows CE 6.0 development environment. 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 109 / 137 

 

3 Configure and Compile WinCE 6.0 Kernel and 

Bootloader 

Configuring a Windows CE6 kernel is very complicated and users may easily to fail if 

they don’t do it carefully. Therefore we prepared a kernel project for users’ reference. You 

can follow the steps below to open and compile it. There is a ready image under 

“images\WindowsCE6” in the shipped CD 

 

3.1 Compile Default Kernel 

Please launch VS2005 to begin compiling the mini6410 BSP.  

Step1: go to “Start”->“Programs”->“Microsoft Visual Studio 2005”-> “Microsoft Visual 

Studio 2005” 

 

Step2: click on “Exit Visual Studio” on the following dialog 
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Step3: Go to “Start”->“Programs”->“VS2005”->“VS2005”, right click on it and you will see 

the following dialog. Select “Property”. We need to run it as administrator. 
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Step4: in the dialog shown below, click on “compatibility” and check the option shown and 

click on “OK”  
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Step5: go to “Start”->“Programs”->“VS2005”->“VS2005” and click on “Continue” and you  

will run it as administrator 



 
 

____________________________________________________________________________________________________________________ 

Address:  Room 1701,Block A2, Longyuan Plaza, 549# Longkouxi Road, Guangzhou, China, 510640 

Website:  http://www.arm9.net           Email:  capbily@163.com  

Tel:      +86-20-85201025             Fax:    +86-20-85261505 

 113 / 137 

 

 
 

Step6: now you will see the initial interface of VS2005 
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Step7: Go to “File->Open->Project/Solution…” 
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Step8: locate your mini6410 file (in this example it was 

C:\WINCE600\OSDesigns\Mini6410-en), click on “Open” 
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Step9: moments later after the mini6410 project is loaded you will see the following dialog 
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Step10: go to “Build->Advanced Build Commands->Clean Sysgen” to begin compilation.  

This process may take a while 
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Step11: after the compilation is done, an NK.bin and an NK.nb0 will be generated under the 

following directory: 

C:\WINCE600\OSDesigns\Mini6410-en\Mini6410\RelDir\Mini6410_ARMV4I_Release 
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3.2 Modify LCD Type and Serial Port in BSP 

Our BSP currently supports the following LCD models:  

NEC 4.3”LCD with touch screen 

TPO 3.5”LCD with touch screen 

Inonux 7”LCD with touch screen

Sharp 8”LCD (or compatible models) with touch screen 

LCD2VGA conversion module: 1024x768, 800x600 and 640x480 
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EZVGA: a simple VGA conversion module, resolution 800x600 

You can define your LCD type by setting up the LCD_TYPE value in 

“\SMDK6410\SRC\INC\options.h”:  

#define LCD_N43 – for NEC4.3”LCD by default 

//#define LCD_T35  

//#define LCD_L80  

//#define LCD_A70  

//#define LCD_VGA1024768  

//#define LCD_VGA800600  

//#define LCD_VGA640480  

//#define LCD_EZVGA 

 

Users can modify the serial port function in “options.h” too:  

// --- by customer  

#define KITL_NONE – default setting  

//#define KITL_SERIAL_UART0  

//#define KITL_SERIAL_UART1  

The default setting here is to make it a common serial port. If you want to set it as an output 

for debugging information you can follow the changes below:  

//#define KITL_NONE  
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#define KITL_SERIAL_UART0  

//#define KITL_SERIAL_UART1 

 

3.3 Configure 1-Wire Precise Touch Screen in BSP 

To facilitate touch screens we especially designed a circuit for accurate touching for the 

Mini6410 system. It utilizes the ADS7843 (or compatible models) chip and incorporates a 

single chip machine to form an independent four wire resistor data collection circuit. It can 

collect accurate data and filter noises and send data to a common GPIO. The PWM1 on the 

board is connected to it and actually we only use GPF15. The driver for the accurate 

touching function has been compiled as a dll(touch_1wire.dll) and integratedinto our BSP. 

But before you can enable the function you need to configure it and compile the kernel. 

Below are the steps to configure it. 

Open “C:\WINCE600\PLATFORM\SMDK6410\ SMDK6410.bat”, locate the following 

lines: 

set BSP_NOTOUCH= 

set BSP_NOTOUCH_ADC=1  

set BSP_NOTOUCHCOM=1  

set BSP_NOTOUCH_1WIRE=  

If an item’s value is null it means the system supports it otherwise the system doesn’t  
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support it therefore if you want to utilize the touch screen control that comes with ARM you 

can do it this way:  

set BSP_NOTOUCH=  

set BSP_NOTOUCH_ADC=  

set BSP_NOTOUCHCOM=1  

set BSP_NOTOUCH_1WIRE=1  

If you want to use the serial port control touch screen you need to make changes as below: 

set BSP_NOTOUCH=  

set BSP_NOTOUCH_ADC=1  

set BSP_NOTOUCHCOM=  

set BSP_NOTOUCH_1WIRE=1  

By default our system is configured to support accurate touching. To differ this kind of 

image from the one that doesn’t support accurate touching we append “-i” to its file name 

such as “NK_A70-i.bin” in the shipped CD. Or you can compile your own kernel that 

supports the serial port touch screen. Previous we differed these two by appending “-s” to its 

file name.  

To test your touch screen you can launch the “Painter” utility in the system. You will find 

it moves very smoothly without vibrations  
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3.4 Bootloader 

In the Mini2440 system the bootloader for WindowsCE5/6 is nboot which is compiled 

with ADS. In the Mini6410 system we name the bootloader “nboot” too and its source code 

is together with the BSP. It needs to be compiled with VS2005. The source code of nboot is 

under “C:\WINCE600\PLATFORM\SMDK6410\SRC\BOOTLOADER”  

This directory includes the following two nboot files:  

nbootRAM128: for 128M RAM system 

nbootRAM256: for 256M RAM system 
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The two nboot will be compiled together. 

As far as functions are concerned the nboot for the Mini6410 is the same as the one for the 

Mini2440. They are simple and less than 8K(the Mini2440’s nboot is less than 4K). In 

general the bootloader will be burned into the NAND Flash’s Block 0 to boot the WinCE 

kernel. Origianlly the nboot was from Samsung and we made some improvements. Our 

version has the following features:  

Support boot logo  

Support process bar for WinCE kernel loading  

Rapid WinCE Booting 

Nboot doesn’t support file buring and can only read files: BootLogo and the WinCE. 

Nboot is easy to be customized. You can set its bootlogo’ position, background and process 

bar’s color, length and width in “options.h”. This file is for the BSP and under 

“SMDK6410\SRC\INC”. 

#define KITL_NONE  

//#define KITL_SERIAL_UART0  

//#define KITL_SERIAL_UART1  

//define LCD type, the default is NEC 4.3”LCD  

#define LCD_N43  

//#define LCD_T35  

//#define LCD_L80  
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//#define LCD_A70  

//#define LCD_VGA1024768  

//#define TOUCH_SCREEN_WIDTH 1024  

//#define TOUCH_SCREEN_HEIGHT 768  

//define background color 

#define BACKGROUND_R 0x00  

#define BACKGROUND_G 0x00  

#define BACKGROUND_B 0x7F  

//define process bar’s color 

#define PROGRESS_BAR_R 0xFF  

#define PROGRESS_BAR_G 0xFF 

#define PROGRESS_BAR_B 0x00  

//define bootlogo’s position 

#define LOGO_POS_TOP 0  

#define LOGO_POS_LEFT 0  

//define process bar’s position, length and width 

#define PROGRESS_BAR_TOP 240  

#define PROGRESS_BAR_LEFT 50  

#define PROGRESS_BAR_WIDTH 400  

#define PROGRESS_BAR_HEIGHT 4  
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Compiling Nboot  

Actually in our previous steps a Nboot has been compiled and an object file “Nboot.nb0” 

is ready for use. Its format is the same as the one compiled with ADS. We now need to burn 

it into the board. It is located under 

“C:\WINCE600\OSDesigns\mini6410\mini6410\RelDir\Samsung_SMDK6410_Release”. 

Compiling a whole WinCE kernel takes a long time. You can just compile the nboot alone. 

In the browser locateyour nboot source code directory, right click on it and select “Build”. 
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Now you need to burn your nboot.nb0 to the NAND flash 

 

3.5 Create SDK 

After you installed VS2005 on your PC but didn’t install Windows CE 6.0 Platform 

Builder, you must have a SDK to develop Mini64140 applications with VS2005. It is very 
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similar to the SDK needed for Embedded Visual C++. 

After you compile your kernel you can set up a SDK via VS2005. Note: this SDK is only 

for VS2005 not for other utilities such as EVC and VS2008. Please follow the steps below to 

do it: 

Step1: start VS2005, open your project file mini6410, right click on “Mini6410-CE6-SDK” 

and select “Build” 

 

 

Step2: moments later the SDK will be built 
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Step3: go to “C:\WINCE600\OSDesigns\mini6410\mini6410\SDKs\mini6410sdk” you will 

be able to find a “Mini6410-CE6-SDK.msi” installation file 

 

 

3.6 Install SDK 

Note: our shipped CD already has an SDK under “WindowsCE6\Mini6410-SDK.msi”. 

Now let’s install an SDK  

Step1: double click on “Mini6410- SDK.msi” and click on “Next” to continue 
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Step2: check “I accept” and click on “Next” to continue 
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Step3: type your user name and company’s name and click on “Next” to continue 
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Step4: click on “Complete” to continue 
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Step5: click on “Next” to continue 
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Step6: click on “Install” to continue 
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Step7: the installation is kicked off 
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Step8: click on “Finish” to complete 
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Now the SDK has been installed successfully 
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